Back to Top

How to connect a Huawei B315s on the 2300MHz band.

Forcing the Huawei B315s router to only connect on the 2300MHz band:

Why would you do this?

Most Telkom towers operate on the 1800mhz band and the 2300mhz band. The majority of mobile devices connect on the 1800mhz band, causing it to be congested at times. Fewer devices are able to connect on the 2300mhz band, making it the ideal connection point for LTE routers.

What do you need?

                  - Username and password to your router.
                  - Network address of your router.
                  - Toolbox.exe application

How to do force the setting:

Download the toolbox.exe application from the following link:

https://www.dropbox.com/s/x3f5jxw89rjk0i9/E5186%20Toolbox_latest.zip?dl=0

Once the download is completed, navigate to the application and open it.

You will be greeted with the following screen:

Your default connections settings are as follows:

IP Address: 192.168.8.1

Username: admin

Password: admin

Click on the  “Connect” button.

Once you are logged in, follow these steps to force your router on the 2300mhz band:


1. Click on the “API Control” tab.

2. Select “api/net/net-mode” from the drop down.

3. Click on the “Get” button. Your two text windows should have updated with some text.

4. Copy and paste the following text in the “Write to API:” box:

<request>
<NetworkMode>03</NetworkMode>
<NetworkBand>8000000000</NetworkBand>
<LTEBand>8000000000</LTEBand>
</request>

 

5. Click on the “Write directly to API” button.

You will be presented with the following confirmation box:

Click on “Yes.”

6. Click on the “Update” button.

Your connection should drop, and connect again. Your router is on the LTE only setting and will only connect to Telkom towers on the 2300mhz band.

If for some reason your connection does not come back, you can reset your router to all its default settings by logging into the web interface and resetting it. Alternatively, you can press the reset button on the router itself.

To revert to the default settings:

Follow the same steps that you took to force the 2300mhz band, but at STEP 4, use the following text instead:

<request>
<NetworkMode>03</NetworkMode>
<NetworkBand>3FFFFFFF</NetworkBand>
<LTEBand>7FFFFFFFFFFFFFFF</LTEBand>
</request>

 

Thank to marlin178 from the mybroadband.co.za forums for all the info and help. Here is a link to our original discussion:

https://mybroadband.co.za/vb/showthread.php/564377-Antenna-installation-and-alignment/page36

 

hvandyk's picture
ABOUT THE AUTHOR